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1. Create a new Project 
On starting Altera Quartus II, you should be faced with a screen like this: 

 
Figure 1. The main Quartus II display. 

 
 
Go to "File -> New Project Wizard".  An introduction Dialog will appear (Fig 2), It 
indicates the capability of this wizard.  You can skip this window in subsequent projects 
by checking the box Don’t show me this introduction again.   



 
 
 
 
 Press Next to get the window shown in Figure 3.  Choose the location of your 
working directory and type in the name of your project (let’s use wrapper) as shown in 
Fig. 3.  



 
Figure. 3  Creation of a new project. 

 
  
Press Next.  Since we have not yet created the directory serialComm, Quartus II software 
displays the pop-up box in Figure 4 asking if it should create the desired directory.   
 

 
Figure. 4  Quartus II software can create a new directory for the project. 

 
Click Yes, which leads to the windows in Figure 5. 
 



 
Figure 5. The wizard can include user-specified design files. 

 
The wizard makes it easy to specify which existing files (if any) should be included in the 
project. Download files shown above from course website and import them into this 
project by press … button.  Then click Next, which leads to the window in Figure 6. 
 



. 
Figure 6. Choose the device family and a specific device. 

 
We have to specify the type of device in which the designed circuit will be implemented. 
Choose Cyclone™ II as the target device family. We can let Quartus II software select a 
specific device in the family, or we can choose the device explicitly. We will take the 
latter approach. From the list of available devices, choose the device called 
EP2C35F672C6 which is the FPGA used on Altera’s DE2 board. Press Next, which 
opens the window in Figure 7.  



 
Figure 7. Other EDA tools can be specified. 

 
The user can specify any third-party tools that should be used. A commonly used term for 
CAD software for electronic circuits is EDA tools, where the acronym stands for 
Electronic Design Automation. This term is used in Quartus II messages that refer to 
third-party tools, which are the tools developed and marketed by companies other than 
Altera. Since we will rely solely on Quartus II tools, we will not choose any other tools. 
Press Next. 
 
A summary of the chosen settings appears in the screen shown in Figure 8. Press Finish, 
which returns to the main Quartus II window, but with wrapper specified as the new 
project, in the display title bar. 
 



 
Figure 8. Summary of the project settings. 

 



 
2. Write your Serial Transceiver Code 
Under the Project Navigator panel, select Files tab.  Then expand the Device Design 
Files in Files tab and select either serialReceiver.v or serialTransmitter.v to open those 
verilog files (Figure 9).  Fill in your code for those two files according to specifications 
provided in lab 2 handout.  Save the file by typing File > Save, or by typing the shortcut 
Ctrl-s. 

 
Figure 9. Edit your serialReceiver.v or serialTransmitter.v 

 





 
3. Pin Assignment 

The DE2 board has hardwired connections between the FPGA pins and the other 
components on the board.  For this project, we need to access LED, LCD. 7-Segment 
LEDs and serial port.  The wrapper file already mapped the input and output pins to their 
default names as used by alter pin assignment file.  To import pin assignment file, first 
we download the pin assignment file from course website 
(http://www.ece.tufts.edu/~hchang/ee129f06/project/project2/DE2_pin_assignments.csv) 
and save it into project directory.  Then choose Assignments > Import Assignments. 
This opens the dialogue in Figure 10 to select the file to import. Type the name of the file 
just downloaded, including the csv extension and the full path to the directory that holds 
the file in the File Name box and press OK.  Of course, you can also browse to find the 
desired file. 

 
Figure 10. Importing the pin assignment. 

 
4. Code Compilation 

The code in the file warpper is processed by several Quartus II tools that analyze 
the code, synthesize the circuit, and generate an implementation of it for the target chip. 
These tools are controlled by the application program called the Compiler. 
Run the Compiler by selecting Processing > Start Compilation, or by clicking on the 
toolbar icon that looks like a purple triangle. As the compilation moves through 
various stages, its progress is reported in a window on the left side of the Quartus II 
display. Successful (or unsuccessful) compilation is indicated in a pop-up box. 
Acknowledge it by clicking OK, which leads to the Quartus II display in Figure 11. In 
the message window, at the bottom of the figure, various messages are displayed. In case 
of errors, there will be appropriate messages given.  When the compilation is finished, a 
compilation report is produced. A window showing this report is opened automatically, 
as seen in Figure 11. The window can be resized, maximized, or closed in the normal 
way, and it can be opened at any time either by selecting Processing > Compilation 

Report or by clicking on the icon . 

http://www.ece.tufts.edu/%7Ehchang/ee129f06/project/project2/DE2_pin_assignments.csv


 
Figure 11. Display after a successful compilation. 

 
 
5. Simulating the Designed Circuit 
Before implementing the designed circuit in the FPGA chip on the DE2 board, it is 
prudent to simulate it to ascertain its correctness. Quartus II software includes a 
simulation tool that can be used to simulate the behavior of a designed circuit. Before the 
circuit can be simulated, it is necessary to create the desired waveforms, called test 
vectors, to represent the input signals. It is also necessary to specify which outputs, as 
well as possible internal points in the circuit, the designer wishes to observe. The 
simulator applies the test vectors to a model of the implemented circuit and determines 
the expected response. We will use the Quartus II Waveform Editor to draw the test 
vectors, as follows: 

Open the Waveform Editor window by selecting File > New.  Click on the Other 
Files tab to reach the window displayed in Figure 12. Choose Vector Waveform File 
and click OK. 



 
Figure 12. Choose to prepare a test-vector file. 

 
 
The Waveform Editor window is depicted in Figure 13. Save the file under the 

name serialComm.vwf. Set the desired simulation to run from 0 to 1 ms by selecting Edit 
> End Time and entering 1 ms in the dialog box that pops up. Selecting View > Fit in 
Window displays the entire simulation range of 0 to 1 ms in the window. 

 
Figure 13.  The Waveform Editor window. 

 
 
Next, we want to include the input and output nodes of the circuit to be simulated. 

Click Edit > Insert Node or Bus to open the window in Figure 14. It is possible to type 
the name of a signal (pin) into the Name box, but it is easier to click on the button 
labeled Node Finder to open the window in Figure 15. The Node Finder utility has a 
filter used to indicate what type of nodes are to be found. Since we are interested in input 
and output pins, set the filter to Pins: all. Click the List button to find the input and 
output nodes as indicated on the left side of the figure. Select signals as shown in the 
right column in Figure 15 and click the > sign to add it to the Selected Nodes box on the 



right side of the figure.  Click Ok to close the Node Finder Window and then Ok in the 
window of Figure 15.  This leaves a fully displayed Waveform Editor window, as shown 
in Figure 16. 

 
Figure 14. The Insert Node or Bus dialogue. 

 

 
Figure 15. Selecting nodes to insert into the Waveform Editor. 



 
Figure 16. The nodes needed for simulation. 

 
Select signal CLOCK_50 by first select the icon , then click signal CLOCK_50.  

Then click the icon  to bring up Figure 17 and fill in values as shown in that figure.  
 

 
Figure 17.  Clock waveform setting for CLOCK_50 

 
 Select signal UART_RXD, then click the icon (once for each column)    to 
bring up Arbitrary Value Dialog and fill in value shown in the following table.  This will 
simulate the transmitting of letter ‘a’ over the serial port. 
 

Start Time (us) 0 100 108.681 117.361 152.083 169.444 178.125
End Time (us) 100 108.681 117.361 152.083 169.444 178.125 1000 

value 1 0 1 0 1 0 1 



A designed circuit can be simulated in two ways. The simplest way is to assume 
that logic elements and interconnection wires in the FPGA are perfect, thus causing no 
delay in propagation of signals through the circuit. This is called functional simulation. A 
more complex alternative is to take all propagation delays into account, which leads to 
timing simulation. Typically, functional simulation is used to verify the functional 
correctness of a circuit as it is being designed. This takes much less time, because the 
simulation can be performed simply by using the logic expressions that define the circuit.  
For the purpose of this project, we need to run a timing simulation to ensure our design 
will work when it is mapped to FPGA. 

To perform the functional simulation, select Assignments > Settings to open the 
Settings window. On the left side of this window click on Simulator to display the 
window in Figure 18, choose Timing as the simulation mode, and make sure that 
simulation input file is serialComm.vwf just created.  Then click OK. The Quartus II 
simulator takes the inputs and generates the outputs defined in the serialComm.vwf file. 

 

 
Figure 18. Specifying the simulation mode. 

 
A simulation run is started by Processing > Start Simulation, or by using the 

icon . At the end of the simulation, Quartus II software indicates its successful 
completion and displays a Simulation Report illustrated in Figure 20.  



 
Figure 20. The result of functional simulation. 

 
6. Programming and Configuring the FPGA Device 

To program DE2 Board, first plug USB Cable to Blaster port of DE2.  When 
computer prompt for drivers, point it to “C:\altera\quartus60\drivers\usb-blaster” 
directory and computer should install the driver and recognize this device.  

The programming and configuration task is performed as follows. Flip the 
RUN/PROG switch (on DE2 Board) into the RUN position. Select Tools > Programmer 
to reach the window in Figure 21. Here it is necessary to specify the programming 
hardware and the mode that should be used. If not already chosen by default, select JTAG 
in the Mode box. Also, if the USB-Blaster is not chosen by default, press the Hardware 
Setup... button and select the USB-Blaster in the window that pops up, as shown in 
Figure 22. 
 

 
Figure 21. The Programmer window. 



 
Figure 22. The updated Programmer window. 

 
Observe that the configuration file wrapper.sof is listed in the window in Figure 

21. If the file is not already listed, then click Add File and select it. This is a binary file 
produced by the Compiler’s Assembler module, which contains the data needed to 
configure the FPGA device. The extension .sof stands for SRAM Object File. Note also 
that the device selected is EP2C35F672, which is the FPGA device used on the DE2 
board. Click on the Program/Configure check box, as shown in Figure 21. Now, press 
Start in the window in Figure 21. An LED on the board will light up when the 
configuration data has been downloaded successfully. If you see an error reported by 
Quartus II software indicating that programming failed, then check to ensure that the 
board is properly powered on. 
 Test your code by connect DE2 board to computer and run your program with 
baud rate set to 115200, 8 bit data length, no parity check and 1 stop bit.  When the data 
is transmitted over the serial port, it binary value is display by LEDR0 to LEDR7 with 
LEDR0 is LSB.  HEX5 and HEX4 display hex value of data, and HEX2, HEX1, HEX0 
display decimal value of data.  The HEX7 and HEX6 acts as a decimal counter, it counts 
from 0 to 99.  The received data is also display on LCD module and transmit back to 
computer. 
 
Appendix: Verilog Syntax and Tutorial online: 
http://www.doe.carleton.ca/~shams/97350/PetervrlK.pdf
http://www.inf.ed.ac.uk/teaching/courses/cd/VerilogTutorial.pdf
 
 

http://www.doe.carleton.ca/%7Eshams/97350/PetervrlK.pdf
http://www.inf.ed.ac.uk/teaching/courses/cd/VerilogTutorial.pdf

